Ergebnis 1 bis 19 von 19

Thema: Koso DB-01R Probleme

  1. #1

    Registriert seit
    14.03.2018
    Ort
    Limburg
    Beiträge
    31
    KTM
    640 BJ. 2003 E auf SM

    Koso DB-01R Probleme

    Moin Jungs,

    so ich habe mal wieder Urlaub und habe mal Zeit wieder etwas am Motorrad zumachen.
    Möchte meinen Koso DB-01R an meinen 640 LC4 2003 anschließen (Digitaltacho).
    Leider komme ich aktuell nicht weiter und kann es mir auch nicht ableiten von anderen Threads.

    Wenn es um Elektrik geht bekomme ich die Krise.

    Diesen Threads kenn ich schon:

    https://www.vwbuswiki.de/index.php/K...u_.28B.Rude.29


    Mit meinem Verständnis bin ich soweit gekommen.

    Kabel vom Koso-Tacho --> Kabelbaum LC4
    schwarz --> braun
    gelb --> blau
    blau --> schwarz
    orange --> violett
    weiß --> grün/schwarz ???
    rot ? --> ??
    grau ? --> ??
    grün? --> dürfte eigentlich ja nicht gehen --> ??

    Habe ich noch Kabel vergessen die wichtig sind?
    Koso hat 8 und der Orignal Digitaltacho hat 13?

    Habe euch mal die Belegung + Plan in den Anhang gepackt.

    Hoffe mir kann jemand weiterhelfen.

    LG

    Tom

    Plan KTM.jpgLegende Plan KTM.jpgKoso Belegung.jpg

  2. #2
    Avatar von KTM Enduro Rider
    Registriert seit
    08.04.2014
    Ort
    Wagenhausen Thurgau Schweiz
    Beiträge
    228
    KTM
    1996er KTM LC4 EGS 400 / 1997er KTM LC4 EGS-E 620
    wenn du die vom tripmaster ausklammerst hast du auch nur noch 9 kabel XD

    Du wirst weiter vorangestossen auf das Problem stossen, dass dein Koso Tacho auch für Temp und Neutralleuchte ein positives signal benötigt. Dies wird erschwert, weil Neutral und Temp über einen Massekontaktschalter (-) gesteuert werden.
    am besagten grün-schwarz kabel liegt negatives signal an welches dein tacho nicht interpretieren kann....auf dem Kehrkabel dazu aber nur konstantes +. Du hast kein + Signal (geschalten) für dein Koso tacho.

    Grundlegend kannst du ein Massesignal mit Relais oder transistoren invertieren um ein + Signal daraus zu machen und die Leuchten vom Koso damit zu steuern.
    Ein relais kann an mit schaltstrom an exakt dieser Stelle verbaut werden um ein externgelegtes + Signal steuerbar zu machen.

    Das sind die schwierigkeiten mit Temp und Netral.

    tankanzeige habe ich noch nicht benutzt. Ich glaube hier ist ein widerstandsmessung der ausschlaggebend ist. Allerdings muss der Koso tacho an exakt den korrekten Widerstand gekoppelt/eingestellt werden um auch nur irgendwas korrekt auszulesen.
    -keine ahnung wo die grenzwerte liegen.

    Rot ist allgemein + Pol also am besten an der tachobeleuchtung klemmen die über zündschloss gesteuert ist.
    Leistung muss mit Können, Vernunft und Aufmerksamkeit gebändigt werden!
    -Wahnsinn ist zwar eine gute Übergangslösung aber nur selten von Dauer!

  3. #3

    Registriert seit
    14.03.2018
    Ort
    Limburg
    Beiträge
    31
    KTM
    640 BJ. 2003 E auf SM
    Könntest du das an Farben eventuell fest machen.
    Hab wirklich keine Ahnung.

    in den anderen Threads ging es eigentlich ich immer so oder habe ich da was falsch verstanden?

  4. #4
    Avatar von KTM Enduro Rider
    Registriert seit
    08.04.2014
    Ort
    Wagenhausen Thurgau Schweiz
    Beiträge
    228
    KTM
    1996er KTM LC4 EGS 400 / 1997er KTM LC4 EGS-E 620
    welche threads?
    - du besitzt eine 2003er KTM mit jedermenge unnötiger elektrischer gedönns.
    Die existieren nicht an älteren maschinen.

    So wie ich das sehe hast du folgende Signal ausgänge am originalen Kabelbaum:
    (reduziert auf die die dich interessieren)

    DU hast also:
    ge-o - Plus über Zündung (mit durchgangsprüfer und Masseanschluss zu prüfen!)
    s - Blinker Rechts (positiver Signal)
    v - Blinker Links (positiver Signal)
    bl - Fernlicht (positiver Signal)
    br - Masse (rate mal)
    ge-bl - Masse Blinker über blinkergeber
    g-s - Neutral (negativer Signal)
    ge-s - Temp (Negativer Signal)

    Temp- und NeutralSignale müssen wie erwähnt invertiert werden um ein geschaltenes + Signal zu erzeugen.

    Problem meine ich auch im bereich vom blinker erkannt zuhaben. Kann gut sein dass deine blinker oder blinkeranzeige nachbearbeitung benötigen (du zwackst die + Signale ab aber der Blinkimpuls kommt über den Blinkergeber in Form von Masse)

    ICH betone ausdrücklich dass ich dir nichts garantieren kann, aber ich habe mit bestem willen die Pläne ausgedruckt und bin sie nachgegangen. Für mich scheint es wie beschrieben sich zu verhalten. Ich habe nichts derartiges studiert war aber Musterschüler im Schulfach elektrotechnik vor bald 20 Jahren XD
    -Ich habe allerdings bis jetzt nur die 1996er LC4 SEM-Modelle und frühen 1997er LC4 Kokusan mit Estart auf diesen Tacho umgerüstet bzw die komplette Maske umgebaut.
    Leistung muss mit Können, Vernunft und Aufmerksamkeit gebändigt werden!
    -Wahnsinn ist zwar eine gute Übergangslösung aber nur selten von Dauer!

  5. #5

    Registriert seit
    14.03.2018
    Ort
    Limburg
    Beiträge
    31
    KTM
    640 BJ. 2003 E auf SM
    Ok, habe mich jetzt nochmal hingesetzt und habe das nochmal probiert zu verstehen.
    Leider ohne Erfolg.

    Effektiv habe ich 7 Kabel die ich beim Koso nutzen kann, damit er alle Kabel verbunden sind.
    Ein Kabel fällt weg (Grün), da die 640 über keine Tankanzeige verfügt.

    Koso Tacho ---> Kabelbaum 640
    Gelb (Fernlicht) -->bl - Fernlicht (positiver Signal)
    Weiß (neutral) --> g-s - Neutral (negativer Signal)
    Orange (Blinker rechts) --> s Blinker Rechts (positiver Signal)
    Blau (Blinker links) --> v Blinker Links (positiver Signal)
    Grau (Ölkontrolleuchte) --> ?
    Rot (Plus-Pol) --> ge-o (bin mir nicht sicher)
    Schwarz (Masse) --> br ( Masse)
    Grün (Kraftstoff) fällt weg, da die 640 eh keine Tankanzeige hat

    Das sind alle Kabel vom Koso Tacho.

    So müsste es doch eigentlich funktionieren bis auf das Signal von weiß --> g-s Neutral, das Signal muss noch invertiert werden.

    Oder müssen vielleicht 2 Kabel auf 1 Kabel verbunden werden???

    Verstehe auch nicht ganz warum die Blinker nochmal zusätzlich Maße brauchen, effektive gehen 2 Kabel an die Blinker.

  6. #6

    Registriert seit
    26.03.2019
    Ort
    im Norden
    Beiträge
    62
    KTM
    LC4 640 E, 400 Mil
    Ein ernstgemeinter Tipp, ohne Abwertung: Suche Dir jemanden der sich bei der KFZ-Elektrik auskennt. Es kann Dir sonst passieren, dass Du sowohl den KOSO, als auch das KTM-Instrument zerschiesst.

    Der Anschluß ge-bl ist eventuell (Vermutung) am Originalinstrument nötig, da nur eine Kontrolleuchte vorhanden ist. Ähnlich ist es bei Zubehörblinkgebern um eine Zuschaltung der anderen Seite zu verhindern, beispielsweise bei Kellermann.

    Wie willst Du die Adaption an den Originalkabelbaum machen?

  7. #7

    Registriert seit
    04.04.2010
    Ort
    Salzburg
    Beiträge
    34
    KTM
    LC4 640 SM 2001
    Schau mal, vieleicht hilft dir dieser thread etwas weiter, da gehts um eine 2001er, musst du halt schauen ob die gleich sind von der belegung her:

    https://vb.ktm-lc4.net/showthread.ph...DB-01R-Problem

  8. #8

    Registriert seit
    14.03.2018
    Ort
    Limburg
    Beiträge
    31
    KTM
    640 BJ. 2003 E auf SM
    Also bin jetzt soweit :

    Koso Tacho --> Kabelbaum 640
    rot an gelb/blau
    weiß an grün/schwarz
    orange an violett
    gelb an blau
    blau an schwarz
    schwarz an braun
    grau --> habe ich aktuell noch nicht verbunden
    grün bleibt frei

    (Kabel kann ich jeder Zeit wieder aufmachen, habe mit Kabelschuhen gearbeitet)

    Also ich bekomme alle Signal angezeigt bis auf Blinker rechts und Neutral (Neutral ging aber bei dem Originaltacho auch schon nicht, hat einfach irgendwann nicht mehr geleuchtet, keine Ahnung woran es liegt, habe es schon kontrolliert).
    Habt ihr noch eine Idee bezüglich das ich mein neutral wieder zum Leuchten bekomme oder was ich nochmal checken könnte, vlt weiß jemand ja einen kleinen Trick.


    Großes Danke schon mal an @KTM Enduro Rider, warst echt einen große Hilfe.


    Ich habe auch ein Blinker Relais verbaut von Kellermann.
    Das hier:
    https://www.kellermann-online.com/pr...blinkrelais-r2

    Hängt es vielleicht an meinem Blinker Relais, dass ich nur Blinker links angezeigt bekomme am Tacho, anstatt Blinker rechts und links?

  9. #9

    Registriert seit
    26.03.2019
    Ort
    im Norden
    Beiträge
    62
    KTM
    LC4 640 E, 400 Mil
    Der Trick ist es die entsprechenden Signale zu messen. Wenn eine Unterbrechung (beispielsweise im Kabelbaum) vorliegt, dann wirst Du den Fehler nur so finden.

    Zum Thema Neutral: Prüfe den Neutralschalter ob er schaltet.
    Geändert von Zehlaus (02.07.2019 um 12:39 Uhr)

  10. #10

    Registriert seit
    14.03.2018
    Ort
    Limburg
    Beiträge
    31
    KTM
    640 BJ. 2003 E auf SM
    C677A9DF-82C4-4FC3-A5A0-28C799B95D3F.jpg

    Ist das der Neutralschalter ?

  11. #11

    Registriert seit
    26.03.2019
    Ort
    im Norden
    Beiträge
    62
    KTM
    LC4 640 E, 400 Mil
    Ja, der schaltet im Leerlauf gegen Masse. Für den Koso musst Du das Signal invertieren, weisst Du wie man das beispielsweise mit einem Relais macht?

  12. #12

    Registriert seit
    14.03.2018
    Ort
    Limburg
    Beiträge
    31
    KTM
    640 BJ. 2003 E auf SM
    Leider nicht genau, wäre super wenn ihr mir Hilfestellung geben könnt.

  13. #13

    Registriert seit
    26.03.2019
    Ort
    im Norden
    Beiträge
    62
    KTM
    LC4 640 E, 400 Mil
    So kann eine Lösung ausehen:
    Angehängte Grafiken Angehängte Grafiken

  14. #14

    Registriert seit
    14.03.2018
    Ort
    Limburg
    Beiträge
    31
    KTM
    640 BJ. 2003 E auf SM
    Ok, habe ich verstanden danke so hätte ich es auch gemacht.
    Jetzt nur die mega peinliche Frage:
    Welche Klemme nehme ich dafür?

    Oh man dass ich sowas fragen muss sry


    Muss nochmal betonen, dass es mir wirklich leid tut sowas zufragen.
    Elektrik ist mir wirklich ein Graus.

  15. #15

    Registriert seit
    26.03.2019
    Ort
    im Norden
    Beiträge
    62
    KTM
    LC4 640 E, 400 Mil
    Elektrik macht richtig Spass, man muss nur wenige Grundlagen lernen. Wenn Du hier im Norden sein würdest, dann hätten wir das an einem Tag abgefrühstückt bei einem Workshop.

    Zur Frage: Du hast doch selbst den Umbaulink in Deinem Post #1 gezeigt, da findest Du die Antworten: Ader 9 gelb/blau - Zündplus, Ader 6 grün/schwarz - Leerlaufschalter

    Hast Du den Leerlaufschalter geprüft?

  16. #16

    Registriert seit
    14.03.2018
    Ort
    Limburg
    Beiträge
    31
    KTM
    640 BJ. 2003 E auf SM
    Ja, dass weiß ich ja aber ich weiß net wie ich das Signal umwandel.
    Du hattest etwas mit einer Klammer erwähnt??
    Wird das in der Klammer dann zusammen geführt oder wie ? (hast du ma ein Bild bzw. Link von so einer Klammer?)

    Ja, wenn man weiß wie es geht ist es immer leicht.

    Leerlaufschalter funktioniert

  17. #17
    Avatar von KTM Enduro Rider
    Registriert seit
    08.04.2014
    Ort
    Wagenhausen Thurgau Schweiz
    Beiträge
    228
    KTM
    1996er KTM LC4 EGS 400 / 1997er KTM LC4 EGS-E 620
    Zitat Zitat von tsnow Beitrag anzeigen
    Ja, dass weiß ich ja aber ich weiß net wie ich das Signal umwandel.
    Du hattest etwas mit einer Klammer erwähnt??
    Wird das in der Klammer dann zusammen geführt oder wie ? (hast du ma ein Bild bzw. Link von so einer Klammer?)

    Ja, wenn man weiß wie es geht ist es immer leicht.

    Leerlaufschalter funktioniert
    Klemme 15 ist ein üblicher Titel für geschaltenes Plus also das Kabel welches bei dir per Zündung +Signal Liefert und tacho mit strom bespeist.. Sonst nichts.

    ES gilt also die signale von Temp und Neutral jeweils zu invertieren mit einem Relais.

    Ein Relais hat folgende Funktion. Wenn ein Schaltstrom gewährleistet ist leitet sie Strom durch die anderen 2 Kontakte (in der Regel 4 Kontakte).

    Leerlauf ist Masse ... Klemme 15 ist positiv. Beide zusammen sind schaltstrom für dein relais.
    Dann musst du ja nur wieder klemme 15 + an den einen Kontakt vom Relais legen, dann kannst du über den letzten Kontakt am Relais wieder dieses + abgreifen und nutzen=> geschaltenes +
    Leistung muss mit Können, Vernunft und Aufmerksamkeit gebändigt werden!
    -Wahnsinn ist zwar eine gute Übergangslösung aber nur selten von Dauer!

  18. #18

    Registriert seit
    26.03.2019
    Ort
    im Norden
    Beiträge
    62
    KTM
    LC4 640 E, 400 Mil
    Wie das Relais anzuschliessen ist zeigt doch meine Skizze in Beitrag #13, als Ergänzung Beitrag #15. Ich habe auch nichts von einer Klammer geschrieben, zur Lösung des Problems und Verständnis vielleicht mal hier schauen: https://www.kfztech.de/kfztechnik/el...eichnungen.htm

    Zeige doch mal Fotos vom jetzigen Zustand des Umbaus. Wie hast Du die Funktion des Leerlaufschalters geprüft?

  19. #19

    Registriert seit
    26.03.2019
    Ort
    im Norden
    Beiträge
    62
    KTM
    LC4 640 E, 400 Mil
    Ist hier jetzt Sendepause? Das Umbauprojekt war ja schon im letzten Jahr ein Thema: KLICK

    Mit der hier erhaltenen Hilfe solltest Du das doch schaffen, oder? Hast Du in Richtung Maskentausch denn schon etwas gemacht? Brauchst Du ggf. ein einbaufertiges Relais?

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •